Nucleus(JP)フォーラム

NucleusCMS日本語版ユーザーのためのサポートフォーラムです。疑問が生じたらまずは記事検索をご利用ください。

ログインしていません。

#1 2004-09-11 14:05:07

ma
メンバー
登録日: 2004-04-01
投稿: 60
ウェブサイト

Re: NP_TrimImage 画像表示しない

お世話になっております。
ver.0.7をインストールさせていただき、
mein indexに<%TrimImage()%>とかいたのですが、表示してくれません。
使用サーバーはXREAで、GDは

GD Support   enabled
GD Version   bundled (2.0.23 compatible)
FreeType Support   enabled
FreeType Linkage   with freetype
GIF Read Support   enabled
JPG Support   enabled
PNG Support   enabled
WBMP Support   enabled
XBM Support   enabled

となっています。このサーバーでは駄目なのでしょうか?
ソースを見ると、

<img src=mydomein.com/nucleus/?action=plugin&name=TrimImage&type=draw&p=1/filename&wsize=80&hsize=80 />

というように書かれてはいるのですが・・・

なにか根本的に間違っているのでしょうか?

オフライン

#2 2004-09-22 12:26:19

はっち
メンバー
From: 岩手
登録日: 2003-11-19
投稿: 251

Re: NP_TrimImage 画像表示しない

何も表示されないって言うのは画像が習得できない時のバツ印もないって言うことですか?
私も何度かバツ印出したことあって、それは画像が壊れてたっていう事だったみたいでした。
うーん。
どなたかXrea広告ありで設置している方はいらっしゃるでしょうか。
aaacafeでテストしたらバツ印出しちゃいました。 :shock:

オフライン

#3 2004-09-22 15:48:08

ma
メンバー
登録日: 2004-04-01
投稿: 60
ウェブサイト

Re: NP_TrimImage 画像表示しない

ありがとうございます。

はい。バツ印など何も表示されません。
ここら辺にでてくるだろうと思われる辺りに、
段差とか枠とかエラーメッセージとか何もありません。

根本的になにか間違っている気もしていますが。

オフライン

#4 2004-09-24 11:58:26

nakahara21
メンバー
From: 尼崎
登録日: 2003-11-14
投稿: 1,298
ウェブサイト

Re: NP_TrimImage 画像表示しない

NP_TrimImageのバージョンはいくつですか?
もし良かったら、自動生成されたimgタグの本物を教えてください!


nakahara21
http://nakahara21.com/
(ただいま調整中です)

オフライン

#5 2004-09-24 14:00:40

ma
メンバー
登録日: 2004-04-01
投稿: 60
ウェブサイト

Re: NP_TrimImage 画像表示しない

バージョンは0.7をインストールさせてもらいました。
本物のタグは

<img src="http://XXX.com/action.php?action=plugin&name=TrimImage&type=draw&p=1/balu.png&wsize=80&hsize=80" />

でした。ごめんなさい。

オフライン

#6 2004-09-26 17:53:37

ma
メンバー
登録日: 2004-04-01
投稿: 60
ウェブサイト

Re: NP_TrimImage 画像表示しない

ひとつわかりました。
なんと、IEではバツ印が出現しているではありませんか。
私は普段Firefoxな為、今まで気づきませんでした。
Firefoxにバツ印は表示しない、というような設定があるのでしょうね。
いろいろ考えていただいたみなさま大変失礼いたしました。

バツ印になってしまうのは、広告のせいなのでしょうか?

オフライン

#7 2004-10-31 01:48:40

naha
ゲストユーザー

Re: NP_TrimImage 画像表示しない

便乗失礼します。
私も TrimImage v0.7 を使わせて頂いていますが、トリミングした画像がバツ印で表示されません。

めちゃめちゃ作りかけで恥ずかしいのですが・・・
問題のページです。
http://umitsuki.net/blog/1

実際に生成されるタグは

<img src="http://umitsuki.net/action.php?action=plugin&name=TrimImage&type=draw&p=1/k_bm09.jpg&wsize=80&hsize=80" width="80" height="80" />

です。

よろしくお願いします><

#8 2004-11-01 08:32:45

nakahara21
メンバー
From: 尼崎
登録日: 2003-11-14
投稿: 1,298
ウェブサイト

Re: NP_TrimImage 画像表示しない

nahaさんのエラーの原因は、サーバに用意されているGDバージョンが要件を満たしていないから、です。
残念です :cry:

原因追及の一番簡単な方法は。
バツ印出ている画像の上で右クリック→プロパティでurlを拾って、そのurl(画像url)を直に叩くとわかります。


nakahara21
http://nakahara21.com/
(ただいま調整中です)

オフライン

#9 2004-11-01 22:29:49

naha
メンバー
登録日: 2004-10-31
投稿: 68

Re: NP_TrimImage 画像表示しない

nakahara21さん>
GDバージョンというものがあるのですね・・・残念です;;
ちょうどサーバの利用期限も近いことだし、移行も考えようかな・・・

原因追及の一番簡単な方法は。
バツ印出ている画像の上で右クリック→プロパティでurlを拾って、そのurl(画像url)を直に叩くとわかります。

たたいてみました。こんなことがわかるんですね!

ありがとうございました。

オフライン

#10 2004-11-29 02:25:38

咲子♂
メンバー
From: 愛知県
登録日: 2004-11-28
投稿: 42
ウェブサイト

Re: NP_TrimImage 画像表示しない

便乗失礼します。
ワタシも、nahaさんのように、画像が表示されないのですが、
やはり、GDのヴァージョンの所為でしょうか?

<img src="http://go.gogo.tc/blog/action.php?action=plugin&name=TrimImage&type=draw&p=1/04.11.01.01.jpg&wsize=60&hsize=60&pnt=lefttop" />

叩いてみましたトコロ

Fatal error: Call to undefined function: imagecreatetruecolor() in c:\www\xxx\xxx\nucleus\plugins\NP_TrimImage.php on line 271

と、出ました。

271行目というと

$im = ImageCreateTrueColor($tsize['w'],$tsize['h']);

ナノですが、正直サッパリです・・・。
どなたかお知恵を拝借出来ませんでしょうか?

NP_ExtractImageも試してみましたが、同じでした。
NP_TrimImageと同様に、205行目の

$im = ImageCreateTrueColor($tsize['w'],$tsize['h']);

がエラーとしてはき出されます。

あ、ExtractImageは0.5、TrimImageは、0.7です。

って、あー!! :cry:
GD2.0.1(たぶん)以上必須。ですか?

PHPテストで
GD Version   1.6.2 or higher
って・・・。

一人大騒ぎでした・・・。

オフライン

#11 2005-03-24 13:51:36

ma
メンバー
登録日: 2004-04-01
投稿: 60
ウェブサイト

Re: NP_TrimImage 画像表示しない

サクラキャンドルさんのおかげです。
ここ
のアドバイスに従い、

サクラキャンドルさん さんの発言:

結論から言うと、XREAの無料サイトでNP_Thumnailを使うと、XREAの広告挿入スクリプトの影響で、ImageJpeg()やImagePng()の出力が正常に行われないことが原因でした。
対策は、action.phpファイルへの広告挿入を抑制することで行います。
action.phpファイルのあるディレクトリの.htaccessファイルに

<Files action.php>
LayoutIgnoreURI *
</Files>

としたらうまく画像出力できました。

念願かないました~

オフライン

Board footer